<!DOCTYPE html>
<html lang="en-US">
<head><meta charset="UTF-8" >
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var u=[],i="/porpoiseant/army.gif";function t(e,i,t,_,d,o,n){if(__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var r=parseInt(__ez.dot.getTargeting(e,"ap")),a=__ez.dot.getSlotIID(e),s=__ez.dot.getAdUnit(e),p=parseInt(__ez.dot.getTargeting(e,"compid")),z=0,f=0,g=function(e){if("undefined"==typeof _ezim_d)return!1;var i=__ez.dot.getAdUnitPath(e).split("/").pop();if("object"==typeof _ezim_d&&_ezim_d.hasOwnProperty(i))return _ezim_d[i];for(var t in _ezim_d)if(t.split("/").pop()===i)return _ezim_d[t];return!1}(e);"object"==typeof g&&(void 0!==g.creative_id&&(f=g.creative_id),void 0!==g.line_item_id&&(z=g.line_item_id)),__ez.dot.isDefined(a,s)&&__ez.dot.isValid(i)&&u.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:_,ad_position:r,ad_size:"",bid_floor_filled:d,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:z,creative_id:f,data:__ez.dot.dataToStr(i)})}}function _(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(u)&&0<u.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(u));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}u=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),_()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var _=t[0],d=t[2];u.push({type:"impression",impression_id:d,domain_id:__ez.dot.getDID(),unit:_,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:_,GetPixels:function(){return u}}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(e,i){this.name=e,this.val=i};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(e,i){this.AddImpPixel(e,i,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(e,i){this.AddPVPixel(e,i),this.FirePixels()},AddImpPixel:function(e,i,t,n,o,a,d){if(0!=__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var s=parseInt(__ez.dot.getTargeting(e,"ap")),r=__ez.dot.getSizes(e)[0],_=r.l.toString()+"x"+r.j.toString(),p="0",l="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(p=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(l=_ezaq.country);var h=__ez.dot.getSlotIID(e),c=__ez.dot.getSlotElementId(e);__ez.dot.isDefined(h,c)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:h,domain_id:p,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:s,ad_size:_,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:d,country_code:l,data:i}))}},AddImpPixelById:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=e.split("/");if(__ez.dot.isDefined(e)&&3===n.length&&this.validateData(i)){var o=n[0],a=n[2];i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:i})}},AddPVPixel:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),__ez.dot.isDefined(e)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"pageview",pageview_id:e,domain_id:t,t_epoch:this.tEpoch,data:i}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(this.pixels)&&0<this.pixels.length&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(e,i){return new EzoicPixelData(e,i)},convertDataToStr:function(e){if(void 0===e)return[];try{for(var i in e)e[i].val=e[i].val+""}catch(e){}return e},validateData:function(e){for(var i=0;i<e.length;i++)if(e[i]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",e[i]),!1;return!0}};</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script>
	<meta name="p:domain_verify" content="ddfb9756c787162052f7210c56317140"/>
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script> (adsbygoogle = window.adsbygoogle || []).push({ google_ad_client: "ca-pub-8111774589457284", enable_page_level_ads: true }); </script>
<!-- Google AdSense Code //-->
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-8111774589457284",
enable_page_level_ads: true
});
</script>
<!-- end Google AdSense Code //-->
	<meta name="yandex-verification" content="d358600740144b8a" />

<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />


<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://techaeris.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://techaeris.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://techaeris.com/feed/atom/" />
<link rel="pingback" href="https://techaeris.com/xmlrpc.php" />

<meta property="og:image" content="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse-1000x543.jpg" />
<meta name="twitter:image" content="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse-1000x543.jpg" />

<meta property="og:type" content="article" />
<meta property="og:description" content=" The Rival 3 gaming mouse has an MSRP of US$29.99, the Apex 3 gaming keyboard for $49.99, and the Apex 5 for $99.99. " />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/">
<meta name="twitter:title" content="SteelSeries adds two new Apex keyboards, Rival mouse to lineup">
<meta name="twitter:description" content=" The Rival 3 gaming mouse has an MSRP of US$29.99, the Apex 3 gaming keyboard for $49.99, and the Apex 5 for $99.99. ">


<title>SteelSeries adds two new Apex keyboards, Rival mouse to lineup</title>

<!-- This site is optimized with the Yoast SEO Premium plugin v12.8.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Not content to sit back after the release of their Apex Pro keyboard, SteelSeries is back with two new Apex keyboards and a new Rival gaming mouse."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="SteelSeries adds two new Apex keyboards, Rival mouse to lineup" />
<meta property="og:description" content="Not content to sit back after the release of their Apex Pro keyboard, SteelSeries is back with two new Apex keyboards and a new Rival gaming mouse." />
<meta property="og:url" content="https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/" />
<meta property="og:site_name" content="Techaeris" />
<meta property="article:publisher" content="https://www.facebook.com/techaeris" />
<meta property="article:tag" content="Apex" />
<meta property="article:tag" content="featured" />
<meta property="article:tag" content="gaming keyboard" />
<meta property="article:tag" content="Gaming Mouse" />
<meta property="article:tag" content="Rival" />
<meta property="article:tag" content="SteelSeries" />
<meta property="article:section" content="Gaming Hardware" />
<meta property="article:published_time" content="2020-01-21T21:45:11+00:00" />
<meta property="article:modified_time" content="2020-01-21T21:45:14+00:00" />
<meta property="og:updated_time" content="2020-01-21T21:45:14+00:00" />
<meta property="og:image" content="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse.jpg" />
<meta property="og:image:secure_url" content="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse.jpg" />
<meta property="og:image:width" content="1085" />
<meta property="og:image:height" content="543" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Not content to sit back after the release of their Apex Pro keyboard, SteelSeries is back with two new Apex keyboards and a new Rival gaming mouse." />
<meta name="twitter:title" content="SteelSeries adds two new Apex keyboards, Rival mouse to lineup" />
<meta name="twitter:site" content="@techaeris" />
<meta name="twitter:image" content="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse.jpg" />
<meta name="twitter:creator" content="@JustAnotherJay" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://techaeris.com/#organization","name":"Techaeris","url":"https://techaeris.com/","sameAs":["https://www.facebook.com/techaeris","https://linkedin.com/company/techaeris","https://www.youtube.com/user/techaeris","https://twitter.com/techaeris"],"logo":{"@type":"ImageObject","@id":"https://techaeris.com/#logo","url":"https://techaeris.com/wp-content/uploads/2019/03/SocialMediaAvatar.jpg","width":800,"height":800,"caption":"Techaeris"},"image":{"@id":"https://techaeris.com/#logo"}},{"@type":"WebSite","@id":"https://techaeris.com/#website","url":"https://techaeris.com/","name":"Techaeris","publisher":{"@id":"https://techaeris.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://techaeris.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/#primaryimage","url":"https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse.jpg","width":1085,"height":543,"caption":"SteelSeries Apex keyboards and Rival gaming mouse"},{"@type":"WebPage","@id":"https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/#webpage","url":"https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/","inLanguage":"en-US","name":"SteelSeries adds two new Apex keyboards, Rival mouse to lineup","isPartOf":{"@id":"https://techaeris.com/#website"},"primaryImageOfPage":{"@id":"https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/#primaryimage"},"datePublished":"2020-01-21T21:45:11+00:00","dateModified":"2020-01-21T21:45:14+00:00","description":"Not content to sit back after the release of their Apex Pro keyboard, SteelSeries is back with two new Apex keyboards and a new Rival gaming mouse."},{"@type":"NewsArticle","@id":"https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/#article","isPartOf":{"@id":"https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/#webpage"},"author":{"@id":"https://techaeris.com/#/schema/person/9cd5f7c2e8a129498fc4a4be3318683b"},"headline":"SteelSeries adds two new Apex keyboards, Rival mouse to lineup","datePublished":"2020-01-21T21:45:11+00:00","dateModified":"2020-01-21T21:45:14+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/#webpage"},"publisher":{"@id":"https://techaeris.com/#organization"},"image":{"@id":"https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/#primaryimage"},"keywords":"Apex,featured,gaming keyboard,Gaming Mouse,Rival,SteelSeries","articleSection":"Gaming,Gaming Hardware,PC","copyrightYear":"2020","copyrightHolder":{"@id":"https://techaeris.com/#organization"}},{"@type":["Person"],"@id":"https://techaeris.com/#/schema/person/9cd5f7c2e8a129498fc4a4be3318683b","name":"Jason Bouwmeester","image":{"@type":"ImageObject","@id":"https://techaeris.com/#authorlogo","url":"https://secure.gravatar.com/avatar/1e1562de713efc5f5c5aacb7297bb042?s=96&d=mm&r=g","caption":"Jason Bouwmeester"},"description":"Married, father of 2 who's also a gaming/tech geek, Xbox Live Ambassador, Google Mapmaker Regional Lead, sometimes photographer, and wannabe guitar player from  Canada. Senior Editor for TECHAERIS.","sameAs":["https://ca.linkedin.com/in/jasonbouwmeester","https://twitter.com/http://www.twitter.com/JustAnotherJay"]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//www.dwin2.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Techaeris &raquo; Feed" href="https://techaeris.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Techaeris &raquo; Comments Feed" href="https://techaeris.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Techaeris &raquo; SteelSeries adds two new Apex keyboards, Rival mouse to lineup Comments Feed" href="https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/techaeris.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=33dd237756b33595f16a54a634b8bf77"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ -->		<script>
			//@formatter:off
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://techaeris.com/wp-includes/css/dist/block-library/style.min.css?ver=33dd237756b33595f16a54a634b8bf77' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://techaeris.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='foobox-noie7-min-css'  href='https://techaeris.com/wp-content/plugins/foobox-image-lightbox/free/css/foobox.noie7.min.css?ver=2.7.8' type='text/css' media='all' />
<link rel='stylesheet' id='icomoon-css'  href='https://techaeris.com/wp-content/plugins/kiwi-social-share-pro/assets/vendors/icomoon/style.css?ver=2.0.7' type='text/css' media='all' />
<link rel='stylesheet' id='lwptoc-main-css'  href='https://techaeris.com/wp-content/plugins/luckywp-table-of-contents/front/assets/main.min.css?ver=1.9.11' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://techaeris.com/wp-includes/css/dashicons.min.css?ver=33dd237756b33595f16a54a634b8bf77' type='text/css' media='all' />
<link rel='stylesheet' id='yop-public-css'  href='https://techaeris.com/wp-content/plugins/yop-poll/public/assets/css/yop-poll-public-6.1.2.css?ver=33dd237756b33595f16a54a634b8bf77' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-photoswipe-css'  href='https://techaeris.com/wp-content/plugins/reviewer/public/assets/css/photoswipe.css?ver=3.14.1' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-public-css'  href='https://techaeris.com/wp-content/plugins/reviewer/public/assets/css/reviewer-public.css?ver=3.14.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-reset-css'  href='https://techaeris.com/wp-content/themes/flex-mag/css/reset.css?ver=33dd237756b33595f16a54a634b8bf77' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css?ver=33dd237756b33595f16a54a634b8bf77' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-style-css'  href='https://techaeris.com/wp-content/themes/flex-mag/style.css?ver=33dd237756b33595f16a54a634b8bf77' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://techaeris.com/wp-content/themes/flex-mag/css/iecss.css?ver=33dd237756b33595f16a54a634b8bf77' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://techaeris.com/wp-content/themes/flex-mag/css/media-queries.css?ver=33dd237756b33595f16a54a634b8bf77' type='text/css' media='all' />
<script type='text/javascript' src='https://techaeris.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://techaeris.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/luckywp-table-of-contents/front/assets/main.min.js?ver=1.9.11'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var objectL10n = {"yopPollParams":{"urlParams":{"ajax":"https:\/\/techaeris.com\/wp-admin\/admin-ajax.php","wpLogin":"https:\/\/techaeris.com\/wp-login.php?redirect_to=https%3A%2F%2Ftechaeris.com%2Fwp-admin%2Fadmin-ajax.php%3Faction%3Dyop_poll_record_wordpress_vote"},"apiParams":{"reCaptcha":{"siteKey":""},"reCaptchaV2Invisible":{"siteKey":""}},"captchaParams":{"imgPath":"https:\/\/techaeris.com\/wp-content\/plugins\/yop-poll\/public\/assets\/img\/","url":"https:\/\/techaeris.com\/wp-content\/plugins\/yop-poll\/app.php","accessibilityAlt":"Sound icon","accessibilityTitle":"Accessibility option: listen to a question and answer it!","accessibilityDescription":"Type below the <strong>answer<\/strong> to what you hear. Numbers or words:","explanation":"Click or touch the <strong>ANSWER<\/strong>","refreshAlt":"Refresh\/reload icon","refreshTitle":"Refresh\/reload: get new images and accessibility option!"},"voteParams":{"invalidPoll":"Invalid Poll","noAnswersSelected":"No answer selected","minAnswersRequired":"At least {min_answers_allowed} answer(s) required","maxAnswersRequired":"A max of {max_answers_allowed} answer(s) accepted","noAnswerForOther":"No other answer entered","noValueForCustomField":"{custom_field_name} is required","consentNotChecked":"You must agree to our terms and conditions","noCaptchaSelected":"Captcha is required","thankYou":"Thank you for your vote"},"resultsParams":{"singleVote":"vote","multipleVotes":"votes","singleAnswer":"answer","multipleAnswers":"answers"}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/yop-poll/public/assets/js/yop-poll-public-6.1.2.min.js?ver=33dd237756b33595f16a54a634b8bf77'></script>
<script type='text/javascript'>
/* Run FooBox FREE (v2.7.8) */
var FOOBOX = window.FOOBOX = {
	ready: true,
	preloadFont: false,
	disableOthers: false,
	o: {wordpress: { enabled: true }, excludes:'.fbx-link,.nofoobox,.nolightbox,a[href*="pinterest.com/pin/create/button/"]', affiliate : { enabled: false }, error: "Could not load the item"},
	selectors: [
		".foogallery-container.foogallery-lightbox-foobox", ".foogallery-container.foogallery-lightbox-foobox-free", ".gallery", ".wp-block-gallery", ".wp-caption", ".wp-block-image", "a:has(img[class*=wp-image-])", ".foobox"
	],
	pre: function( $ ){
		// Custom JavaScript (Pre)
		
	},
	post: function( $ ){
		// Custom JavaScript (Post)
		
		// Custom Captions Code
		
	},
	custom: function( $ ){
		// Custom Extra JS
		
	}
};
</script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/foobox-image-lightbox/free/js/foobox.free.min.js?ver=2.7.8'></script>
<link rel='https://api.w.org/' href='https://techaeris.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://techaeris.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://techaeris.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://techaeris.com/?p=162236' />
<link rel="alternate" type="application/json+oembed" href="https://techaeris.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftechaeris.com%2F2020%2F01%2F21%2Fsteelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://techaeris.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftechaeris.com%2F2020%2F01%2F21%2Fsteelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup%2F&#038;format=xml" />
<script language="javascript">
<!--
if (navigator.userAgent.match(/iPad/i) != null) {
document.write("<meta name=\"apple-itunes-app\" content=\"app-id=1091720542\">\n");
}
else {
document.write("<meta name=\"apple-itunes-app\" content=\"app-id=1091720542\">");
}
// -->
</script>
    
<!-- LionScripts: Webmaster Tools Head Start -->
<meta name="google-site-verification" content="fUTrCPciMcf97CjZo4XwKJqog9FTqO0Y89HJKDSbvzE" /><meta name='msvalidate.01' content='A30BE89A492F9BCFAA26414401284A3A'>
<!-- LionScripts: Webmaster Tools Head End -->
<style type="text/css">
.post-last-modified, .page-last-modified { color: #bbb!important; font-size: .8rem!important; };
</style>


<!-- Last Modified Schema is inserted by the WP Last Modified Info plugin v1.6.5 - https://wordpress.org/plugins/wp-last-modified-info/ -->
<script type="application/ld+json">{"@context":"http:\/\/schema.org\/","@type":"CreativeWork","dateModified":"2020-01-21T15:45:14-06:00","headline":"SteelSeries adds two new Apex keyboards, Rival mouse to lineup","description":" The Rival 3 gaming mouse has an MSRP of US$29.99, the Apex 3 gaming keyboard for $49.99, and the Apex 5 for $99.99. ","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/techaeris.com\/2020\/01\/21\/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup\/"},"author":{"@type":"Person","name":"Jason Bouwmeester","url":"https:\/\/techaeris.com\/author\/jason-bouwmeester\/","description":"Married, father of 2 who&#039;s also a gaming\/tech geek, Xbox Live Ambassador, Google Mapmaker Regional Lead, sometimes photographer, and wannabe guitar player from  Canada. Senior Editor for TECHAERIS."}}</script>

<!-- Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/techaeris.com\/2020\/01\/21\/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup\/"},"headline":"SteelSeries adds two new Apex keyboards, Rival mouse to lineup","image":{"@type":"ImageObject","url":"https:\/\/techaeris.com\/wp-content\/uploads\/2020\/01\/SteelSeries-Apex-keyboards-Rival-mouse.jpg","width":1085,"height":543},"datePublished":"2020-01-21T15:45:11","dateModified":"2020-01-21T15:45:14","author":{"@type":"Person","name":"Jason Bouwmeester"},"publisher":{"@type":"Organization","name":"Techaeris","logo":{"@type":"ImageObject","url":"https:\/\/techaeris.com\/wp-content\/uploads\/2019\/03\/SocialMediaAvatar-60x60.jpg","width":60,"height":60}},"description":"The Rival 3 gaming mouse has an MSRP of US$29.99, the Apex 3 gaming keyboard for $49.99, and the Apex 5 for $99.99."}</script><!-- / Schema optimized by Schema Pro --><!-- organization Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"NewsMediaOrganization","name":"Techaeris","url":"https:\/\/techaeris.com","logo":{"@type":"ImageObject","url":"https:\/\/techaeris.com\/wp-content\/uploads\/2019\/03\/SocialMediaAvatar.jpg","width":800,"height":800},"sameAs":["https:\/\/www.facebook.com\/techaeris","http:\/\/twitter.com\/techaeris","https:\/\/www.youtube.com\/user\/techaeris","https:\/\/linkedin.com\/company\/techaeris"]}</script><!-- / organization Schema optimized by Schema Pro --><!-- site-navigation-element Schema optimized by Schema Pro --><script type="application/ld+json">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</script><!-- / site-navigation-element Schema optimized by Schema Pro --><!-- breadcrumb Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/techaeris.com\/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/techaeris.com\/gaming\/","name":"Gaming"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/techaeris.com\/2020\/01\/21\/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup\/","name":"SteelSeries adds two new Apex keyboards, Rival mouse to lineup"}}]}</script><!-- / breadcrumb Schema optimized by Schema Pro --><style type="text/css">.rwp-review-wrap {
	padding: 10px;
	background-color: #eee;
}
.rwp-review-wrap .rwp-review .rwp-scores .rwp-criterion .rwp-criterion-bar-base .rwp-score-bar { height: 20px; }
.rwp-review-wrap .rwp-review .rwp-scores .rwp-criterion .rwp-criterion-bar-base { height: 20px; background: #bbb; }
.rwp-review-wrap .rwp-review .rwp-header .rwp-pros-wrap, .rwp-review-wrap .rwp-review .rwp-header .rwp-pros-wrap { max-width: 550px; }
.rwp-review-wrap .rwp-review .rwp-header .rwp-pros-wrap, .rwp-review-wrap .rwp-review .rwp-header .rwp-cons-wrap { max-width: 550px; }
.rwp-review-wrap .rwp-review .rwp-custom-links a { font-size: 1em!important;
    margin: 0 5px 5px 0;
    display: inline-block;
    padding: 8px 17px;
    color: #fff!important;
    background: #467073;
    text-decoration: none!important;
    text-transform: uppercase;
    border-radius: 2px; }
.rwp-review-wrap .rwp-review .rwp-custom-links a:hover { background:#232323!important; }
.rwp-review-wrap .rwp-review .rwp-title { display: none; }
.rwp-pros, .rwp-cons, .rwp-summary { font-size: 16px!important; }
.rwp-criterion-label {font-size: 18px!important;}</style>
<style type='text/css'>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</style>
	
<style type="text/css">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</style>

<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ededed; }
</style>
	<link rel="icon" href="https://techaeris.com/wp-content/uploads/2018/09/cropped-websiteavatar-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://techaeris.com/wp-content/uploads/2018/09/cropped-websiteavatar-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://techaeris.com/wp-content/uploads/2018/09/cropped-websiteavatar-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://techaeris.com/wp-content/uploads/2018/09/cropped-websiteavatar-270x270.jpg" />


<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-118311416-51";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-118311416-51']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'techaeris.com']);
_gaq.push(['f._setDomainName', 'techaeris.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod20-c',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','techaeris.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 71059;
var ezdomain = 'techaeris.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":71059,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"5ad0e1ad-6040-4dcd-619c-9f377acc69cf","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":208,"serverid":"54.152.24.39:21430","state":"VA","t_epoch":1579646915,"template_id":126,"time_on_site_visit":0,"url":"https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/","user_id":0,"word_count":1246,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-4&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_71059=" + new Date().getTime() + "|5ad0e1ad-6040-4dcd-619c-9f377acc69cf; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>

<body class="post-template-default single single-post postid-162236 single-format-standard custom-background wp-schema-pro-1.5.0 "><!-- LionScripts: Webmaster Tools Body Start -->
<!-- Google Tag Manager (noscript) -->
							<noscript><iframe src="https://www.googletagmanager.com/ns.html?id="
							height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
							<!-- End Google Tag Manager (noscript) -->
<!-- LionScripts: Webmaster Tools Body End -->
							<meta type="lionscripts:webmaster-tools">
	<div id="site" class="left relative">
		<div id="site-wrap" class="left relative">
						<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
									<li class="fb-soc">
						<a href="https://www.facebook.com/TECHAERIS" target="_blank">
						<i class="fa fa-facebook-square fa-2"></i>
						</a>
					</li>
													<li class="twit-soc">
						<a href="https://www.twitter.com/TECHAERIS" target="_blank">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
													<li class="pin-soc">
						<a href="https://www.pinterest.com/34dp0znlg39yq9ipurfgyr4m53gyip/" target="_blank">
						<i class="fa fa-pinterest fa-2"></i>
						</a>
					</li>
																	<li class="goog-soc">
						<a href="https://www.subscribestar.com/techaeris" target="_blank">
						<i class="fa fa-google-plus fa-2"></i>
						</a>
					</li>
													<li class="yt-soc">
						<a href="https://www.youtube.com/user/techaeris" target="_blank">
						<i class="fa fa-youtube-play fa-2"></i>
						</a>
					</li>
																					<li class="rss-soc">
						<a href="https://techaeris.com/feed/rss/" target="_blank">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-primarymenu-container"><ul id="menu-primarymenu" class="menu"><li id="menu-item-38218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38218"><a href="https://techaeris.com/news/">Latest News</a></li>
<li id="menu-item-16525" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16525"><a href="https://techaeris.com/technology/">Tech</a>
<ul class="sub-menu">
	<li id="menu-item-25503" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25503"><a href="https://techaeris.com/technology/apple/">Apple</a></li>
	<li id="menu-item-25504" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25504"><a href="https://techaeris.com/technology/google/">Google</a></li>
	<li id="menu-item-25505" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25505"><a href="https://techaeris.com/technology/microsoft/">Microsoft</a></li>
	<li id="menu-item-16520" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16520"><a href="https://techaeris.com/mobile/">Mobile</a>
	<ul class="sub-menu">
		<li id="menu-item-25500" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25500"><a href="https://techaeris.com/mobile/android/">Android</a></li>
		<li id="menu-item-25501" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25501"><a href="https://techaeris.com/mobile/ios/">iOS</a></li>
		<li id="menu-item-25502" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25502"><a href="https://techaeris.com/mobile/windows-phone/">Windows Phone</a></li>
		<li id="menu-item-25506" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25506"><a href="https://techaeris.com/mobile/wearables/">Wearables</a></li>
	</ul>
</li>
	<li id="menu-item-160539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-160539"><a href="https://techaeris.com/technology/smart-home-smart-devices/">Smart Home &amp; Smart Devices</a></li>
	<li id="menu-item-26051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26051"><a href="https://techaeris.com/technology/security/">Security</a></li>
	<li id="menu-item-136517" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136517"><a href="https://techaeris.com/home-theater/">Home Theater</a></li>
	<li id="menu-item-76227" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76227"><a href="https://techaeris.com/drones/">Drones</a></li>
	<li id="menu-item-16524" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16524"><a href="https://techaeris.com/science/">Science</a></li>
	<li id="menu-item-26933" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26933"><a href="https://techaeris.com/audio/">Audio</a></li>
	<li id="menu-item-16515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16515"><a href="https://techaeris.com/auto/">Auto</a></li>
	<li id="menu-item-42543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42543"><a href="https://techaeris.com/gadgets-toys/">Gadgets &#038; Toys</a></li>
	<li id="menu-item-51280" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51280"><a href="https://techaeris.com/fitness-health/">Fitness &#038; Health</a></li>
	<li id="menu-item-16521" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16521"><a href="https://techaeris.com/photography/">Photography</a></li>
	<li id="menu-item-16516" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16516"><a href="https://techaeris.com/business/">Business</a></li>
	<li id="menu-item-16522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16522"><a href="https://techaeris.com/press-releases/">Press Releases</a></li>
</ul>
</li>
<li id="menu-item-41836" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-41836"><a href="https://techaeris.com/gaming/">Gaming</a>
<ul class="sub-menu">
	<li id="menu-item-42099" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42099"><a href="https://techaeris.com/gaming/xbox/">Xbox</a></li>
	<li id="menu-item-42098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42098"><a href="https://techaeris.com/gaming/playstation/">PlayStation</a></li>
	<li id="menu-item-63487" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-63487"><a href="https://techaeris.com/gaming/gaming-hardware/">Gaming Hardware</a></li>
	<li id="menu-item-42093" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42093"><a href="https://techaeris.com/gaming/android-gaming/">Android Gaming</a></li>
	<li id="menu-item-42094" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42094"><a href="https://techaeris.com/gaming/ios-gaming/">iOS Gaming</a></li>
	<li id="menu-item-42096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42096"><a href="https://techaeris.com/gaming/nintendo/">Nintendo</a></li>
	<li id="menu-item-42097" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42097"><a href="https://techaeris.com/gaming/pc-gaming/">PC</a></li>
</ul>
</li>
<li id="menu-item-16523" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16523"><a href="https://techaeris.com/reviews/">Reviews</a>
<ul class="sub-menu">
	<li id="menu-item-52613" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52613"><a href="https://techaeris.com/reviews/top-picks/">Top Picks</a></li>
	<li id="menu-item-42105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42105"><a href="https://techaeris.com/reviews/hardware-reviews/">Hardware Reviews</a></li>
	<li id="menu-item-42101" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42101"><a href="https://techaeris.com/reviews/audio-hardware-reviews/">Audio Hardware Reviews</a></li>
	<li id="menu-item-42106" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42106"><a href="https://techaeris.com/reviews/mobile-reviews/">Mobile Reviews</a></li>
	<li id="menu-item-160305" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-160305"><a href="https://techaeris.com/reviews/smart-home-and-smart-devices-reviews/">Smart Home &#038; Smart Device Reviews</a></li>
	<li id="menu-item-97808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97808"><a href="https://techaeris.com/reviews/gaming-hardware-reviews/">Gaming Hardware Reviews</a></li>
	<li id="menu-item-136518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136518"><a href="https://techaeris.com/reviews/home-theater-reviews/">Home Theater Reviews</a></li>
	<li id="menu-item-77227" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77227"><a href="https://techaeris.com/reviews/comicbook-reviews/">Comic/Book Reviews</a></li>
	<li id="menu-item-42104" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42104"><a href="https://techaeris.com/reviews/game-reviews/">Game Reviews</a></li>
	<li id="menu-item-42114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42114"><a href="https://techaeris.com/reviews/wearables-reviews/">Wearables Reviews</a></li>
	<li id="menu-item-42107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42107"><a href="https://techaeris.com/reviews/movie-reviews/">Movie Reviews</a></li>
	<li id="menu-item-42109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42109"><a href="https://techaeris.com/reviews/tv-show-reviews/">TV Show Reviews</a></li>
	<li id="menu-item-42100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42100"><a href="https://techaeris.com/reviews/app-software-reviews/">App/Software Reviews</a></li>
	<li id="menu-item-51281" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51281"><a href="https://techaeris.com/reviews/fitness-reviews/">Fitness &#038; Health Reviews</a></li>
	<li id="menu-item-76132" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76132"><a href="https://techaeris.com/reviews/furniture-reviews/">Furniture Reviews</a></li>
	<li id="menu-item-88626" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88626"><a href="https://techaeris.com/reviews/drone-reviews/">Drone Reviews</a></li>
	<li id="menu-item-42103" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42103"><a href="https://techaeris.com/reviews/gadget-toy-reviews/">Gadget &#038; Toy Reviews</a></li>
</ul>
</li>
<li id="menu-item-41835" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-41835"><a href="https://techaeris.com/entertainment/">Entertainment</a>
<ul class="sub-menu">
	<li id="menu-item-42089" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42089"><a href="https://techaeris.com/entertainment/movies/">Movies</a></li>
	<li id="menu-item-42090" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42090"><a href="https://techaeris.com/entertainment/music/">Music</a></li>
	<li id="menu-item-42092" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42092"><a href="https://techaeris.com/entertainment/tv/">TV</a></li>
	<li id="menu-item-42088" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42088"><a href="https://techaeris.com/entertainment/comics-books/">Comics/Books</a></li>
	<li id="menu-item-42091" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42091"><a href="https://techaeris.com/entertainment/pop-culture/">Pop Culture</a></li>
</ul>
</li>
<li id="menu-item-16517" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16517"><a href="https://techaeris.com/editorial/">Editorials</a></li>
<li id="menu-item-19554" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19554"><a href="https://techaeris.com/how-to/">How To</a></li>
<li id="menu-item-38201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38201"><a href="https://techaeris.com/giveaways/">Giveaways</a></li>
<li id="menu-item-38205" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38205"><a href="https://techaeris.com/love-the-content-we-create-support-us/">Support Techaeris</a></li>
<li id="menu-item-38202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-38202"><a href="https://techaeris.com/about/">About Us</a>
<ul class="sub-menu">
	<li id="menu-item-38203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38203"><a href="https://techaeris.com/advertise-us/">Advertise With Us</a></li>
	<li id="menu-item-38229" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38229"><a href="https://techaeris.com/site-news/">Site News</a></li>
	<li id="menu-item-38204" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38204"><a href="https://techaeris.com/contact-ustips/">Contact Us/Tips</a></li>
	<li id="menu-item-99022" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-99022"><a href="https://techaeris.com/disclaimer/">Disclaimer</a></li>
</ul>
</li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->			<div id="head-main-wrap" class="left relative">
				<div id="head-main-top" class="left relative">
																																<div class="logo-wide-wrap left relative">
															<a itemprop="url" href="https://techaeris.com/"><img itemprop="logo" src="https://techaeris.com/wp-content/uploads/2019/10/WebsiteHeadFINALNEW3-2.png" alt="Techaeris" data-rjs="2" /></a>
																						<h2 class="mvp-logo-title">Techaeris</h2>
													</div><!--logo-wide-wrap-->
									</div><!--head-main-top-->
				<div id="main-nav-wrap">
					<div class="nav-out">
						<div class="nav-in">
							<div id="main-nav-cont" class="left" itemscope itemtype="http://schema.org/Organization">
								<div class="nav-logo-out">
									<div class="nav-left-wrap left relative">
										<div class="fly-but-wrap left relative">
											<span></span>
											<span></span>
											<span></span>
											<span></span>
										</div><!--fly-but-wrap-->
																					<div class="nav-logo-fade left">
																									<a href="https://techaeris.com/"><img src="https://techaeris.com/wp-content/uploads/2019/10/WebsiteHeadFINALNEW3-1.png" alt="Techaeris" data-rjs="2" /></a>
																							</div><!--nav-logo-fade-->
																			</div><!--nav-left-wrap-->
									<div class="nav-logo-in">
										<div class="nav-menu-out">
											<div class="nav-menu-in">
												<nav class="main-menu-wrap left">
													<div class="menu-primarymenu-container"><ul id="menu-primarymenu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38218"><a href="https://techaeris.com/news/">Latest News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16525"><a href="https://techaeris.com/technology/">Tech</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25503"><a href="https://techaeris.com/technology/apple/">Apple</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25504"><a href="https://techaeris.com/technology/google/">Google</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25505"><a href="https://techaeris.com/technology/microsoft/">Microsoft</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16520"><a href="https://techaeris.com/mobile/">Mobile</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25500"><a href="https://techaeris.com/mobile/android/">Android</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25501"><a href="https://techaeris.com/mobile/ios/">iOS</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25502"><a href="https://techaeris.com/mobile/windows-phone/">Windows Phone</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25506"><a href="https://techaeris.com/mobile/wearables/">Wearables</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-160539"><a href="https://techaeris.com/technology/smart-home-smart-devices/">Smart Home &amp; Smart Devices</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26051"><a href="https://techaeris.com/technology/security/">Security</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136517"><a href="https://techaeris.com/home-theater/">Home Theater</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76227"><a href="https://techaeris.com/drones/">Drones</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16524"><a href="https://techaeris.com/science/">Science</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26933"><a href="https://techaeris.com/audio/">Audio</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16515"><a href="https://techaeris.com/auto/">Auto</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42543"><a href="https://techaeris.com/gadgets-toys/">Gadgets &#038; Toys</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51280"><a href="https://techaeris.com/fitness-health/">Fitness &#038; Health</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16521"><a href="https://techaeris.com/photography/">Photography</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16516"><a href="https://techaeris.com/business/">Business</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16522"><a href="https://techaeris.com/press-releases/">Press Releases</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-41836"><a href="https://techaeris.com/gaming/">Gaming</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42099"><a href="https://techaeris.com/gaming/xbox/">Xbox</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42098"><a href="https://techaeris.com/gaming/playstation/">PlayStation</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-63487"><a href="https://techaeris.com/gaming/gaming-hardware/">Gaming Hardware</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42093"><a href="https://techaeris.com/gaming/android-gaming/">Android Gaming</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42094"><a href="https://techaeris.com/gaming/ios-gaming/">iOS Gaming</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42096"><a href="https://techaeris.com/gaming/nintendo/">Nintendo</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42097"><a href="https://techaeris.com/gaming/pc-gaming/">PC</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16523"><a href="https://techaeris.com/reviews/">Reviews</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52613"><a href="https://techaeris.com/reviews/top-picks/">Top Picks</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42105"><a href="https://techaeris.com/reviews/hardware-reviews/">Hardware Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42101"><a href="https://techaeris.com/reviews/audio-hardware-reviews/">Audio Hardware Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42106"><a href="https://techaeris.com/reviews/mobile-reviews/">Mobile Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-160305"><a href="https://techaeris.com/reviews/smart-home-and-smart-devices-reviews/">Smart Home &#038; Smart Device Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97808"><a href="https://techaeris.com/reviews/gaming-hardware-reviews/">Gaming Hardware Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136518"><a href="https://techaeris.com/reviews/home-theater-reviews/">Home Theater Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77227"><a href="https://techaeris.com/reviews/comicbook-reviews/">Comic/Book Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42104"><a href="https://techaeris.com/reviews/game-reviews/">Game Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42114"><a href="https://techaeris.com/reviews/wearables-reviews/">Wearables Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42107"><a href="https://techaeris.com/reviews/movie-reviews/">Movie Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42109"><a href="https://techaeris.com/reviews/tv-show-reviews/">TV Show Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42100"><a href="https://techaeris.com/reviews/app-software-reviews/">App/Software Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51281"><a href="https://techaeris.com/reviews/fitness-reviews/">Fitness &#038; Health Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76132"><a href="https://techaeris.com/reviews/furniture-reviews/">Furniture Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88626"><a href="https://techaeris.com/reviews/drone-reviews/">Drone Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42103"><a href="https://techaeris.com/reviews/gadget-toy-reviews/">Gadget &#038; Toy Reviews</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-41835"><a href="https://techaeris.com/entertainment/">Entertainment</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42089"><a href="https://techaeris.com/entertainment/movies/">Movies</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42090"><a href="https://techaeris.com/entertainment/music/">Music</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42092"><a href="https://techaeris.com/entertainment/tv/">TV</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42088"><a href="https://techaeris.com/entertainment/comics-books/">Comics/Books</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42091"><a href="https://techaeris.com/entertainment/pop-culture/">Pop Culture</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16517"><a href="https://techaeris.com/editorial/">Editorials</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19554"><a href="https://techaeris.com/how-to/">How To</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38201"><a href="https://techaeris.com/giveaways/">Giveaways</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38205"><a href="https://techaeris.com/love-the-content-we-create-support-us/">Support Techaeris</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-38202"><a href="https://techaeris.com/about/">About Us</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38203"><a href="https://techaeris.com/advertise-us/">Advertise With Us</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38229"><a href="https://techaeris.com/site-news/">Site News</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38204"><a href="https://techaeris.com/contact-ustips/">Contact Us/Tips</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-99022"><a href="https://techaeris.com/disclaimer/">Disclaimer</a></li>
</ul>
</li>
</ul></div>												</nav>
											</div><!--nav-menu-in-->
											<div class="nav-right-wrap relative">
												<div class="nav-search-wrap left relative">
													<span class="nav-search-but left"><i class="fa fa-search fa-2"></i></span>
													<div class="search-fly-wrap">
														<form method="get" id="searchform" action="https://techaeris.com/">
	<input type="text" name="s" id="s" value="Type search term and press enter" onfocus='if (this.value == "Type search term and press enter") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Type search term and press enter"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>													</div><!--search-fly-wrap-->
												</div><!--nav-search-wrap-->
																									<a href="https://www.facebook.com/TECHAERIS" target="_blank">
													<span class="nav-soc-but"><i class="fa fa-facebook fa-2"></i></span>
													</a>
																																					<a href="https://www.twitter.com/TECHAERIS" target="_blank">
													<span class="nav-soc-but"><i class="fa fa-twitter fa-2"></i></span>
													</a>
																							</div><!--nav-right-wrap-->
										</div><!--nav-menu-out-->
									</div><!--nav-logo-in-->
								</div><!--nav-logo-out-->
							</div><!--main-nav-cont-->
						</div><!--nav-in-->
					</div><!--nav-out-->
				</div><!--main-nav-wrap-->
			</div><!--head-main-wrap-->
										<div id="body-main-wrap" class="left relative" itemscope itemtype="http://schema.org/NewsArticle">
					<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/"/>
																																			<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="body-main-cont" class="left relative">
																			<div id="leader-wrap" class="left relative">
								<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- November2017AdUnit -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-8111774589457284"
     data-ad-slot="1015350462"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>							</div><!--leader-wrap-->
												<div id="post-main-wrap" class="left relative">
	<div class="post-wrap-out1">
		<div class="post-wrap-in1">
			<div id="post-left-col" class="relative">
									<article id="post-area" class="post-162236 post type-post status-publish format-standard has-post-thumbnail hentry category-gaming category-gaming-hardware category-pc-gaming tag-apex tag-featured tag-gaming-keyboard tag-gaming-mouse tag-rival tag-steelseries">
													<header id="post-header">
								                                <h1 class="post-title entry-title left" itemprop="name headline">SteelSeries adds two new Apex keyboards, Rival mouse to lineup</h1>
									                                        <span class="post-list-cat">
                                            
                                            Gaming / Gaming Hardware / PC                                            
                                        </span>
                                																	
																	<div id="post-info-wrap" class="left relative">
										<div class="post-info-out">
											<div class="post-info-img left relative">
												<img alt='' src='https://secure.gravatar.com/avatar/1e1562de713efc5f5c5aacb7297bb042?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1e1562de713efc5f5c5aacb7297bb042?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />											</div><!--post-info-img-->
											<div class="post-info-in">
												<div class="post-info-right left relative">
													<div class="post-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
														<span class="post-info-text">By</span> <span class="author-name vcard fn author" itemprop="name"><a href="https://techaeris.com/author/jason-bouwmeester/" title="Posts by Jason Bouwmeester" rel="author">Jason Bouwmeester</a></span> <span class="author-twitter"><a href="http://www.twitter.com/JustAnotherJay" class="twitter-but" target="_blank"><i class="fa fa-twitter fa-2"></i></a></span> <span class="author-email"><a href="mailto:jasonb@techaeris.com"><i class="fa fa-envelope fa-2"></i></a></span>													</div><!--post-info-name-->
													<div class="post-info-date left relative">
														<span class="post-info-text">Posted on</span> <span class="post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-01-21">January 21, 2020</time></span>
														<meta itemprop="dateModified" content="2020-01-21"/>
													</div><!--post-info-date-->
												</div><!--post-info-right-->
											</div><!--post-info-in-->
										</div><!--post-info-out-->
									</div><!--post-info-wrap-->
															</header><!--post-header-->
																																																									<div id="post-feat-img" class="left relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
												<img width="1085" height="543" src="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse.jpg" class="attachment- size- wp-post-image" alt="SteelSeries Apex keyboards and Rival gaming mouse" srcset="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse.jpg 1085w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse-400x200.jpg 400w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse-150x75.jpg 150w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse-768x384.jpg 768w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse-50x25.jpg 50w" sizes="(max-width: 1085px) 100vw, 1085px" />																								<meta itemprop="url" content="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse.jpg">
												<meta itemprop="width" content="1085">
												<meta itemprop="height" content="543">
												<div class="post-feat-text">
																											<span class="post-excerpt left"><p> The Rival 3 gaming mouse has an MSRP of US$29.99, the Apex 3 gaming keyboard for $49.99, and the Apex 5 for $99.99. </p>
</span>
																																						</div><!--post-feat-text-->
											</div><!--post-feat-img-->
																																														<div id="content-area" itemprop="articleBody" class="post-162236 post type-post status-publish format-standard has-post-thumbnail hentry category-gaming category-gaming-hardware category-pc-gaming tag-apex tag-featured tag-gaming-keyboard tag-gaming-mouse tag-rival tag-steelseries">
							<div class="post-cont-out">
								<div class="post-cont-in">
									<div id="content-main" class="left relative">

																															
																																				<ul class="kiwi-article-bar pill kiwi-article-bar-fit " data-tracking="true" data-tracking-container="article-bar" ><li><a data-class="popup" data-network="facebook" class="kiwi-nw-facebook" href="//www.facebook.com/sharer.php?u=https%3A%2F%2Ftechaeris.com%2F2020%2F01%2F21%2Fsteelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup%2F" target="_blank" rel="nofollow"><span class="kicon-facebook"></span> </a></li><li><a data-class="popup" data-network="twitter" class="kiwi-nw-twitter" href="//twitter.com/intent/tweet?text=SteelSeries%20adds%20two%20new%20Apex%20keyboards,%20Rival%20mouse%20to%20lineup&#038;url=https%3A%2F%2Ftechaeris.com%2F2020%2F01%2F21%2Fsteelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup%2F&#038;via=techaeris" target="_blank" rel="nofollow"><span class="kicon-twitter"></span> </a></li><li><a data-class="popup" data-network="linkedin" class="kiwi-nw-linkedin" href="//linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Ftechaeris.com%2F2020%2F01%2F21%2Fsteelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup%2F&#038;title=SteelSeries+adds+two+new+Apex+keyboards%2C+Rival+mouse+to+lineup" target="_blank" rel="nofollow"><span class="kicon-linkedin"></span> </a></li><li><a data-class="popup" data-network="telegram" class="kiwi-nw-telegram" href="//telegram.me/share/url?url=https%3A%2F%2Ftechaeris.com%2F2020%2F01%2F21%2Fsteelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup%2F&#038;text=SteelSeries+adds+two+new+Apex+keyboards%2C+Rival+mouse+to+lineup" target="_blank" rel="nofollow"><span class="kicon-telegram"></span> </a></li><li><a data-class="popup" data-network="reddit" class="kiwi-nw-reddit" href="//reddit.com/submit?url=https%3A%2F%2Ftechaeris.com%2F2020%2F01%2F21%2Fsteelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup%2F" target="_blank" rel="nofollow"><span class="kicon-reddit"></span> </a></li><li><a data-class="popup" data-network="pinterest" class="kiwi-nw-pinterest" href="//pinterest.com/pin/create/button/?url=https%3A%2F%2Ftechaeris.com%2F2020%2F01%2F21%2Fsteelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup%2F&#038;description=&#038;media=https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse.jpg" target="_blank" rel="nofollow"><span class="kicon-pinterest"></span> </a></li></ul>
<p>Gaming peripherals are a big industry and SteelSeries has been in the game for a while now.  We&#8217;ve reviewed some of the company&#8217;s <a rel="noreferrer noopener" aria-label="Apex gaming keyboards (opens in a new tab)" href="https://techaeris.com/?s=steelseries+apex+review" target="_blank">Apex gaming keyboards</a> and <a rel="noreferrer noopener" aria-label="Rival gaming mice (opens in a new tab)" href="https://techaeris.com/?s=steelseries+rival+review" target="_blank">Rival gaming mice</a> in the past and a few have even garnered our Top Pick Award. Not content to sit back after the release of their Apex Pro gaming keyboard, SteelSeries is back with two new keyboards and a new Rival gaming mouse.</p>



<blockquote class="wp-block-quote"><p> “There are so many gamers out there that are stuck using boring, traditional office peripherals for gaming. With these new products, we set office products in our sights and sought to retool our cutting-edge technologies and put them into products that are accessible for every gamer. No one should have to be stuck using run-of-the-mill office products for gaming.” </p><cite> Ehtisham Rabbani, SteelSeries CEO </cite></blockquote>



<h2>Rival 3 Gaming Mouse</h2>



<p>SteelSeries is going bright with this one with new unique and brilliant RGB lighting. The new performance-focused TrueMove Core optical sensor has true 1-to-1 tracking and 8,500 CPI. The mouse switches are also rated for 60 million clicks and it has five onboard memory slots to save different CPI profiles. </p><div class="techa-content" id="techa-580507325"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- November2017AdUnit -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-8111774589457284"
     data-ad-slot="1015350462"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



<div class="wp-block-image"><figure class="aligncenter size-large is-resized"><a href="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Rival-3-Gaming-Mouse.jpg"><img src="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Rival-3-Gaming-Mouse.jpg" alt="SteelSeries Rival 3 gaming mouse" class="wp-image-162246" width="200" height="272" srcset="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Rival-3-Gaming-Mouse.jpg 800w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Rival-3-Gaming-Mouse-294x400.jpg 294w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Rival-3-Gaming-Mouse-110x150.jpg 110w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Rival-3-Gaming-Mouse-768x1044.jpg 768w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Rival-3-Gaming-Mouse-37x50.jpg 37w" sizes="(max-width: 200px) 100vw, 200px" /></a><figcaption>SteelSeries Rival 3 gaming mouse.</figcaption></figure></div>



<p>Features and specifications of the Rival 3 gaming mouse include:</p>



<ul><li>TrueMove Core Optical Sensor with 8,500 CPI and 1-to-1 tracking</li><li>Crazy bright RGB lights</li><li>Comfortable &amp; durable design</li><li>Five on-board CPI profiles</li><li>60M click switch durability (the same switches as the Rival 650)</li><li>SteelSeries Engine customization</li><li> 8,500 CPI (counts per inch)</li><li>300 IPS (inches per second)</li><li>35g Acceleration</li><li>77g weight</li></ul>



<h2>Apex 3 Gaming Keyboard</h2>



<p>The new Apex 3 gaming keyboard features whisper-quiet gaming switches (rated for over 20 million keypresses), 10-zone RGB lighting, anti-ghosting, and is also IP32 water-resistant to save your keyboard from accidental spills. Other features include dedicated media keys, clickable metal roller, a three-way cable routing system, and a high-quality magnetic wrist rest.</p>



<div class="wp-block-image"><figure class="aligncenter size-large is-resized"><a href="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-3-gaming-keyboard.jpg"><img src="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-3-gaming-keyboard.jpg" alt="SteelSeries Apex 3 gaming keyboard" class="wp-image-162247" width="600" height="419" srcset="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-3-gaming-keyboard.jpg 1200w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-3-gaming-keyboard-400x279.jpg 400w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-3-gaming-keyboard-150x105.jpg 150w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-3-gaming-keyboard-768x536.jpg 768w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-3-gaming-keyboard-50x35.jpg 50w" sizes="(max-width: 600px) 100vw, 600px" /></a><figcaption>SteelSeries Apex 3 gaming keyboard.</figcaption></figure></div>



<p>Features and specifications of the Apex 3 gaming keyboard include:</p>



<ul><li>Whisper-Quiet POM reinforced membrane switches</li><li>10-zone RGB lighting</li><li>Comfortable &amp; durable design</li><li>Dedicated multimedia controls</li><li>Three-way cable routing</li><li>Gaming grade anti-ghosting</li><li>Detachable wrist rest</li><li>GameSense</li><li>Discord integration, chat notifications</li></ul>



<h2>Apex 5 Gaming Keyboard</h2>



<p>The Apex 5 features hybrid blue mechanical/membrane switches for added durability and performance. In addition to a premium magnetic wrist rest, media controls, and volume roller, this gaming keyboard also includes a customizable OLED screen.</p>



<div class="wp-block-image"><figure class="aligncenter size-large is-resized"><a href="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-5-gaming-keyboard.jpg"><img src="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-5-gaming-keyboard.jpg" alt="SteelSeries Apex 5 gaming keyboard" class="wp-image-162248" width="600" height="388" srcset="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-5-gaming-keyboard.jpg 1200w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-5-gaming-keyboard-400x258.jpg 400w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-5-gaming-keyboard-150x97.jpg 150w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-5-gaming-keyboard-768x496.jpg 768w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-5-gaming-keyboard-50x32.jpg 50w" sizes="(max-width: 600px) 100vw, 600px" /></a><figcaption>SteelSeries Apex 5 gaming keyboard.</figcaption></figure></div>



<p>Features and specifications of the Apex 5 gaming keyboard include:</p>



<ul><li>Hybrid blue mechanical/membrane switches</li><li>Standard MX keycaps with 4mm throw</li><li>OLED Smart Display</li><li>Dynamic per-key RGB lighting</li><li>Dedicated multimedia controls with volume wheel</li><li>Five onboard profiles</li><li>Three-way cable routing</li><li>Gaming grade 10-key rollover with anti-ghosting</li><li>Premium magnetic wrist rest (similar to the one on the Apex Pro/Apex 7)</li><li>Aircraft-grade aluminum alloy chassis</li><li>GameSense</li></ul>



<p>Gaming peripherals can be pricey but a couple of the new SteelSeries options are definitely affordable and easy on the wallet. The <a href="https://amzn.to/38oAbkE" target="_blank" rel="noreferrer noopener" aria-label="Rival 3 gaming mouse (opens in a new tab)">Rival 3 gaming mouse</a> has an MSRP of US$29.99, the <a href="https://amzn.to/2RB0UUs" target="_blank" rel="noreferrer noopener" aria-label="Apex 3 gaming keyboard (opens in a new tab)">Apex 3 gaming keyboard</a> for $49.99, and the <a href="https://amzn.to/2tHtTOm" target="_blank" rel="noreferrer noopener" aria-label="Apex 5 (opens in a new tab)">Apex 5</a> for $99.99. All three are available now.</p>



<p>What do you think about the new SteelSeries Apex keyboards and Rival mouse? Let us know in the comments below or on <a href="https://twitter.com/Techaeris" target="_blank" rel="noopener noreferrer">Twitter</a>, <a href="https://www.facebook.com/techaeris/" target="_blank" rel="noopener noreferrer">Facebook</a>, or <a href="https://mewe.com/p/techaeris">MeWe</a>.</p>



<h6> *We use revenue-generating affiliate links and may earn a commission for purchases made using them. Read more on our <a rel="noreferrer noopener" href="https://techaeris.com/disclaimer/" target="_blank">disclaimer page.</a> </h6>
<p class="post-last-modified">Last Updated on <time class="post-last-modified-td">January 21, 2020</time></p>																														<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
											<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
																									<img src="https://techaeris.com/wp-content/uploads/2019/10/WebsiteHeadFINALNEW3-2.png"/>
													<meta itemprop="url" content="https://techaeris.com/wp-content/uploads/2019/10/WebsiteHeadFINALNEW3-2.png">
																							</div><!--mvp-org-logo-->
											<meta itemprop="name" content="Techaeris">
										</div><!--mvp-org-wrap-->
										<div class="posts-nav-link">
																					</div><!--posts-nav-link-->
																					<div class="post-tags">
												<span class="post-tags-header">Related Items:</span><span itemprop="keywords"><a href="https://techaeris.com/tag/apex/" rel="tag">Apex</a>, <a href="https://techaeris.com/tag/featured/" rel="tag">featured</a>, <a href="https://techaeris.com/tag/gaming-keyboard/" rel="tag">gaming keyboard</a>, <a href="https://techaeris.com/tag/gaming-mouse/" rel="tag">Gaming Mouse</a>, <a href="https://techaeris.com/tag/rival/" rel="tag">Rival</a>, <a href="https://techaeris.com/tag/steelseries/" rel="tag">SteelSeries</a></span>
											</div><!--post-tags-->
																																									            <div class="mvp-related-posts left relative">
		<h4 class="post-header"><span class="post-header">Recommended for you</span></h4>
			<ul>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://techaeris.com/2020/01/14/razer-deathadder-and-basilisk-upgraded-with-advanced-mouse-technology/" rel="bookmark" title="Razer DeathAdder and Basilisk upgraded with advanced mouse technology">
						<img width="300" height="180" src="https://techaeris.com/wp-content/uploads/2020/01/Razer-DeathAdder-V2-Gaming-Mouse-300x180.jpg" class="reg-img wp-post-image" alt="Razer DeathAdder V2 wired gaming mouse" srcset="https://techaeris.com/wp-content/uploads/2020/01/Razer-DeathAdder-V2-Gaming-Mouse-300x180.jpg 300w, https://techaeris.com/wp-content/uploads/2020/01/Razer-DeathAdder-V2-Gaming-Mouse-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://techaeris.com/wp-content/uploads/2020/01/Razer-DeathAdder-V2-Gaming-Mouse-80x80.jpg" class="mob-img wp-post-image" alt="Razer DeathAdder V2 wired gaming mouse" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://techaeris.com/2020/01/14/razer-deathadder-and-basilisk-upgraded-with-advanced-mouse-technology/">Razer DeathAdder and Basilisk upgraded with advanced mouse technology</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://techaeris.com/2020/01/12/ces-2020-altec-lansing-expands-into-gaming-accessories-market/" rel="bookmark" title="[CES 2020] Altec Lansing expands into gaming accessories market">
						<img width="300" height="180" src="https://techaeris.com/wp-content/uploads/2020/01/Altec-Lansing-gaming-accessories-300x180.jpg" class="reg-img wp-post-image" alt="Altec Lansing gaming accessories display at CES 2020" srcset="https://techaeris.com/wp-content/uploads/2020/01/Altec-Lansing-gaming-accessories-300x180.jpg 300w, https://techaeris.com/wp-content/uploads/2020/01/Altec-Lansing-gaming-accessories-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://techaeris.com/wp-content/uploads/2020/01/Altec-Lansing-gaming-accessories-80x80.jpg" class="mob-img wp-post-image" alt="Altec Lansing gaming accessories display at CES 2020" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://techaeris.com/2020/01/12/ces-2020-altec-lansing-expands-into-gaming-accessories-market/">[CES 2020] Altec Lansing expands into gaming accessories market</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://techaeris.com/2020/01/05/ces-2020-lenovos-first-egpu-announced-alongside-new-legion-gaming-laptop-monitors-peripherals/" rel="bookmark" title="[CES 2020] Lenovo&#8217;s first eGPU announced alongside new Legion gaming laptop, monitors, peripherals">
						<img width="300" height="180" src="https://techaeris.com/wp-content/uploads/2020/01/Lenovo-Legion-eGPU-300x180.jpg" class="reg-img wp-post-image" alt="Lenovo Legion eGPU" srcset="https://techaeris.com/wp-content/uploads/2020/01/Lenovo-Legion-eGPU-300x180.jpg 300w, https://techaeris.com/wp-content/uploads/2020/01/Lenovo-Legion-eGPU-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://techaeris.com/wp-content/uploads/2020/01/Lenovo-Legion-eGPU-80x80.jpg" class="mob-img wp-post-image" alt="Lenovo Legion eGPU" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://techaeris.com/2020/01/05/ces-2020-lenovos-first-egpu-announced-alongside-new-legion-gaming-laptop-monitors-peripherals/">[CES 2020] Lenovo&#8217;s first eGPU announced alongside new Legion gaming laptop, monitors, peripherals</a>
				</div><!--related-text-->
            			</li>
            		</ul></div>																															<div id="article-ad">
												<div id="as2271" data-title="You Might Also Like"></div>
<script type="text/javascript">
 !function(w,d,a){if(!w[a]){var s=d.createElement('script'),
 x=d.getElementsByTagName('script')[0];s.type='text/javascript';
 s.async=!0;s.src ='//widgets.ad.style/native.js';x.parentNode
 .insertBefore(s,x);}w[a]=w[a]||function(){(w[a].q=w[a].q||[])
 .push(arguments)};}(window, document, '_as');
_as('create',{wi:2271});
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- November2017AdUnit -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-8111774589457284"
     data-ad-slot="1015350462"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>											</div><!--article-ad-->
																																																							<div id="comments-button" class="left relative comment-click-162236 com-but-162236">
													<span class="comment-but-text"><span class="dsq-postid" data-dsqidentifier="162236 https://techaeris.com/?p=162236">Comments</span></span>
												</div><!--comments-button-->
												<div id="disqus_thread" class="disqus-thread-162236"></div>
    <script type="text/javascript">
        var disqus_shortname = "techaeris";
        var disqus_title = "SteelSeries adds two new Apex keyboards, Rival mouse to lineup";
        var disqus_url = "https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/";
        var disqus_identifier = "techaeris-162236";
    </script>																														</div><!--content-main-->
								</div><!--post-cont-in-->
															</div><!--post-cont-out-->
						</div><!--content-area-->
					</article>
																			</div><!--post-left-col-->
			</div><!--post-wrap-in1-->
							<div id="post-right-col" class="relative">
																		<div id="sidebar-wrap" class="left relative">
						<div id="custom_html-23" class="widget_text side-widget widget_custom_html"><h4 class="post-header"><span class="post-header">Lenovo at CES 2020</span></h4><div class="textwidget custom-html-widget"><a href="https://techaeris.com/lenovo-at-ces-2020/"><img src="https://techaeris.com/wp-content/uploads/2019/12/Lenovo-CES-2020-Sidebar.jpg" /></a></div></div><div id="custom_html-22" class="widget_text side-widget widget_custom_html"><h4 class="post-header"><span class="post-header">Amazon Electronics Gift Guide</span></h4><div class="textwidget custom-html-widget"><iframe src="//rcm-na.amazon-adsystem.com/e/cm?o=1&p=290&l=ur1&category=ecgg_amz&banner=1FVME8Y9PCYPMK7NN1G2&f=ifr&linkID=49f30e194d191bfa70e7cbb3f5da8f0d&t=techaeris-20&tracking_id=techaeris-20" width="320" height="250" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></div></div>			<div class="widget-ad left relative">
				<div id="as2270" data-title="You Might Also Like"></div>
<script type="text/javascript">
 !function(w,d,a){if(!w[a]){var s=d.createElement('script'),
 x=d.getElementsByTagName('script')[0];s.type='text/javascript';
 s.async=!0;s.src ='//widgets.ad.style/native.js';x.parentNode
 .insertBefore(s,x);}w[a]=w[a]||function(){(w[a].q=w[a].q||[])
 .push(arguments)};}(window, document, '_as');
_as('create',{wi:2270});
</script>			</div><!--widget-ad-->
					<div class="widget-ad left relative">
				Enter ad <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- November2017AdUnit -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-8111774589457284"
     data-ad-slot="1015350462"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>code here			</div><!--widget-ad-->
					<div class="widget-ad left relative">
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- November2017AdUnit -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-8111774589457284"
     data-ad-slot="1015350462"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			</div><!--widget-ad-->
		<div id="custom_html-5" class="widget_text side-widget widget_custom_html"><h4 class="post-header"><span class="post-header">Amazon Deals!</span></h4><div class="textwidget custom-html-widget"><script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=c71c7fbb-f5e7-45bb-b852-67ee3ac48c58"></script></div></div><div id="mvp_catrow_widget-6" class="side-widget mvp_catrow_widget"><h4 class="post-header"><span class="post-header">Latest Tech News</span></h4>			<div class="row-widget-wrap left relative">
				<ul class="row-widget-list">
											<li>
							<a href="https://techaeris.com/2020/01/21/plugable-adds-512gb-option-to-thunderbolt-3-nvme-external-ssd-drive-line-up/" rel="bookmark">
															<div class="row-widget-img left relative">
										<img width="300" height="180" src="https://techaeris.com/wp-content/uploads/2020/01/Plugable-Thunderbolt-3-NVMe-External-SSD-drive-300x180.jpg" class="reg-img wp-post-image" alt="Plugable Thunderbolt 3 NVMe External SSD drive" srcset="https://techaeris.com/wp-content/uploads/2020/01/Plugable-Thunderbolt-3-NVMe-External-SSD-drive-300x180.jpg 300w, https://techaeris.com/wp-content/uploads/2020/01/Plugable-Thunderbolt-3-NVMe-External-SSD-drive-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />										<img width="80" height="80" src="https://techaeris.com/wp-content/uploads/2020/01/Plugable-Thunderbolt-3-NVMe-External-SSD-drive-80x80.jpg" class="mob-img wp-post-image" alt="Plugable Thunderbolt 3 NVMe External SSD drive" />																		<div class="feat-info-wrap">
										<div class="feat-info-views">
											<i class="fa fa-eye fa-2"></i> <span class="feat-info-text">12</span>
										</div><!--feat-info-views-->
																			</div><!--feat-info-wrap-->
																										</div><!--row-widget-img-->
														<div class="row-widget-text">
																										<span class="side-list-cat">									
									Tech                                
                                 	</span>
																								<p>Plugable adds 512GB option to Thunderbolt 3 NVMe External SSD drive line up</p>
							</div><!--row-widget-text-->
							</a>
						</li>
											<li>
							<a href="https://techaeris.com/2020/01/18/fiora-ultimate-wireless-car-charger-turns-your-phone-into-a-dashcam/" rel="bookmark">
															<div class="row-widget-img left relative">
										<img width="300" height="180" src="https://techaeris.com/wp-content/uploads/2020/01/Fiora-Ultimate-Wireless-Car-Charger-with-phone-300x180.jpg" class="reg-img wp-post-image" alt="Fiora Ultimate Wireless Car Charger with phone" srcset="https://techaeris.com/wp-content/uploads/2020/01/Fiora-Ultimate-Wireless-Car-Charger-with-phone-300x180.jpg 300w, https://techaeris.com/wp-content/uploads/2020/01/Fiora-Ultimate-Wireless-Car-Charger-with-phone-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />										<img width="80" height="80" src="https://techaeris.com/wp-content/uploads/2020/01/Fiora-Ultimate-Wireless-Car-Charger-with-phone-80x80.jpg" class="mob-img wp-post-image" alt="Fiora Ultimate Wireless Car Charger with phone" />																		<div class="feat-info-wrap">
										<div class="feat-info-views">
											<i class="fa fa-eye fa-2"></i> <span class="feat-info-text">77</span>
										</div><!--feat-info-views-->
																			</div><!--feat-info-wrap-->
																										</div><!--row-widget-img-->
														<div class="row-widget-text">
																										<span class="side-list-cat">									
									Android / iOS / Mobile / Tech                                
                                 	</span>
																								<p>Fiora Ultimate Wireless Car Charger turns your phone into a dashcam</p>
							</div><!--row-widget-text-->
							</a>
						</li>
											<li>
							<a href="https://techaeris.com/2020/01/17/is-this-new-electric-jet-ski-worth-us24000/" rel="bookmark">
															<div class="row-widget-img left relative">
										<img width="300" height="180" src="https://techaeris.com/wp-content/uploads/2020/01/Tiaga-Motors-Orca-300x180.jpg" class="reg-img wp-post-image" alt="Tiaga Motors Orca" srcset="https://techaeris.com/wp-content/uploads/2020/01/Tiaga-Motors-Orca-300x180.jpg 300w, https://techaeris.com/wp-content/uploads/2020/01/Tiaga-Motors-Orca-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />										<img width="80" height="80" src="https://techaeris.com/wp-content/uploads/2020/01/Tiaga-Motors-Orca-80x80.jpg" class="mob-img wp-post-image" alt="Tiaga Motors Orca" />																		<div class="feat-info-wrap">
										<div class="feat-info-views">
											<i class="fa fa-eye fa-2"></i> <span class="feat-info-text">74</span>
										</div><!--feat-info-views-->
																			</div><!--feat-info-wrap-->
																										</div><!--row-widget-img-->
														<div class="row-widget-text">
																										<span class="side-list-cat">									
									Auto / Tech                                
                                 	</span>
																								<p>Is this new electric jet ski worth US$24,000?</p>
							</div><!--row-widget-text-->
							</a>
						</li>
									</ul>
			</div><!--row-widget-wrap-->
		</div>			<div class="widget-ad left relative">
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- November2017AdUnit -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-8111774589457284"
     data-ad-slot="1015350462"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			</div><!--widget-ad-->
		<div id="custom_html-8" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-8111774589457284"
     data-ad-slot="1546112441"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>			</div><!--sidebar-wrap-->															</div><!--post-right-col-->
					</div><!--post-wrap-out1-->
</div><!--post-main-wrap-->
			<div id="prev-next-wrap">
							<div id="prev-post-wrap">
					<div id="prev-post-arrow" class="relative">
						<i class="fa fa-angle-left fa-4"></i>
					</div><!--prev-post-arrow-->
					<div class="prev-next-text">
						<a href="https://techaeris.com/2020/01/18/where-is-xur-and-what-is-he-selling-week-of-january-17-21st/" rel="prev">Where is Xur, and what is he selling? Week of January 17-21st</a>					</div><!--prev-post-text-->
				</div><!--prev-post-wrap-->
								</div><!--prev-next-wrap-->
														<div id="foot-ad-wrap" class="left relative">
								<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- November2017AdUnit -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-8111774589457284"
     data-ad-slot="1015350462"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>							</div><!--foot-ad-wrap-->
											</div><!--body-main-cont-->
				</div><!--body-main-in-->
			</div><!--body-main-out-->
			<footer id="foot-wrap" class="left relative">
				<div id="foot-top-wrap" class="left relative">
					<div class="body-main-out relative">
						<div class="body-main-in">
							<div id="foot-widget-wrap" class="left relative">
																<div id="text-49" class="foot-widget left relative widget_text"><h3 class="foot-head">About Techaeris</h3>			<div class="textwidget"><p>Techaeris was founded in 2013 by Alex Hernandez who is the Editor-In-Chief and Owner. Techaeris is fast becoming your new source for technology news, technology reviews and all things geek/nerd entertainment related. We cover movies, comics, books, gaming, tech and industry news all in one clean place.</p>
</div>
		</div><div id="mvp_taglist_widget-2" class="foot-widget left relative mvp_taglist_widget"><h3 class="foot-head">Latest News</h3>			<div class="blog-widget-wrap left relative">
				<ul class="blog-widget-list left relative">
											<li>
							<a href="https://techaeris.com/2020/01/21/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup/" rel="bookmark">
															<div class="blog-widget-img left relative">
									<img width="300" height="180" src="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse-300x180.jpg" class="widget-img-main wp-post-image" alt="SteelSeries Apex keyboards and Rival gaming mouse" srcset="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse-300x180.jpg 300w, https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />									<img width="80" height="80" src="https://techaeris.com/wp-content/uploads/2020/01/SteelSeries-Apex-keyboards-Rival-mouse-80x80.jpg" class="widget-img-side wp-post-image" alt="SteelSeries Apex keyboards and Rival gaming mouse" />																		<div class="feat-info-wrap">
										<div class="feat-info-views">
											<i class="fa fa-eye fa-2"></i> <span class="feat-info-text">4</span>
										</div><!--feat-info-views-->
																			</div><!--feat-info-wrap-->
																										</div><!--blog-widget-img-->
														<div class="blog-widget-text left relative">
																	<span class="side-list-cat">									
									Gaming / Gaming Hardware / PC                                
                                 	</span>
																<h2>SteelSeries adds two new Apex keyboards, Rival mouse to lineup</h2>
								<p>The Rival 3 gaming mouse has an MSRP of US$29.99, the Apex 3 gaming...</p>
							</div><!--blog-widget-text-->
							</a>
						</li>
											<li>
							<a href="https://techaeris.com/2020/01/21/plugable-adds-512gb-option-to-thunderbolt-3-nvme-external-ssd-drive-line-up/" rel="bookmark">
															<div class="blog-widget-img left relative">
									<img width="300" height="180" src="https://techaeris.com/wp-content/uploads/2020/01/Plugable-Thunderbolt-3-NVMe-External-SSD-drive-300x180.jpg" class="widget-img-main wp-post-image" alt="Plugable Thunderbolt 3 NVMe External SSD drive" srcset="https://techaeris.com/wp-content/uploads/2020/01/Plugable-Thunderbolt-3-NVMe-External-SSD-drive-300x180.jpg 300w, https://techaeris.com/wp-content/uploads/2020/01/Plugable-Thunderbolt-3-NVMe-External-SSD-drive-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />									<img width="80" height="80" src="https://techaeris.com/wp-content/uploads/2020/01/Plugable-Thunderbolt-3-NVMe-External-SSD-drive-80x80.jpg" class="widget-img-side wp-post-image" alt="Plugable Thunderbolt 3 NVMe External SSD drive" />																		<div class="feat-info-wrap">
										<div class="feat-info-views">
											<i class="fa fa-eye fa-2"></i> <span class="feat-info-text">12</span>
										</div><!--feat-info-views-->
																			</div><!--feat-info-wrap-->
																										</div><!--blog-widget-img-->
														<div class="blog-widget-text left relative">
																	<span class="side-list-cat">									
									Tech                                
                                 	</span>
																<h2>Plugable adds 512GB option to Thunderbolt 3 NVMe External SSD drive line up</h2>
								<p>The drive is available for a limited launch discount of US$179, a $20 savings...</p>
							</div><!--blog-widget-text-->
							</a>
						</li>
											<li>
							<a href="https://techaeris.com/2020/01/21/simplehuman-sensor-can-with-voice-control-review-smart-devices-arent-always-connected/" rel="bookmark">
															<div class="blog-widget-img left relative">
									<img width="300" height="180" src="https://techaeris.com/wp-content/uploads/2020/01/simplehuman-sensor-can-with-voice-control-top-pick-300x180.jpg" class="widget-img-main wp-post-image" alt="Simplehuman sensor can with voice control" srcset="https://techaeris.com/wp-content/uploads/2020/01/simplehuman-sensor-can-with-voice-control-top-pick-300x180.jpg 300w, https://techaeris.com/wp-content/uploads/2020/01/simplehuman-sensor-can-with-voice-control-top-pick-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />									<img width="80" height="80" src="https://techaeris.com/wp-content/uploads/2020/01/simplehuman-sensor-can-with-voice-control-top-pick-80x80.jpg" class="widget-img-side wp-post-image" alt="Simplehuman sensor can with voice control" />																		<div class="feat-info-wrap">
										<div class="feat-info-views">
											<i class="fa fa-eye fa-2"></i> <span class="feat-info-text">18</span>
										</div><!--feat-info-views-->
																			</div><!--feat-info-wrap-->
																										</div><!--blog-widget-img-->
														<div class="blog-widget-text left relative">
																	<span class="side-list-cat">									
									Hardware Reviews / Reviews / Smart Home &amp; Smart Device Reviews                                
                                 	</span>
																<h2>Simplehuman Sensor Can with voice control review: Smart devices aren&#8217;t always connected</h2>
								<p>The Simplehuman Sensor Can with voice control is a motion and voice-activated trash can...</p>
							</div><!--blog-widget-text-->
							</a>
						</li>
											<li>
							<a href="https://techaeris.com/2020/01/20/totallee-wireless-charger-review-just-about-perfect/" rel="bookmark">
															<div class="blog-widget-img left relative">
									<img width="300" height="180" src="https://techaeris.com/wp-content/uploads/2020/01/totallee-wireless-charger-FI-300x180.jpg" class="widget-img-main wp-post-image" alt="" srcset="https://techaeris.com/wp-content/uploads/2020/01/totallee-wireless-charger-FI-300x180.jpg 300w, https://techaeris.com/wp-content/uploads/2020/01/totallee-wireless-charger-FI-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />									<img width="80" height="80" src="https://techaeris.com/wp-content/uploads/2020/01/totallee-wireless-charger-FI-80x80.jpg" class="widget-img-side wp-post-image" alt="" />																		<div class="feat-info-wrap">
										<div class="feat-info-views">
											<i class="fa fa-eye fa-2"></i> <span class="feat-info-text">30</span>
										</div><!--feat-info-views-->
																			</div><!--feat-info-wrap-->
																										</div><!--blog-widget-img-->
														<div class="blog-widget-text left relative">
																	<span class="side-list-cat">									
									Hardware Reviews / Mobile Reviews / Reviews                                
                                 	</span>
																<h2>totallee Wireless Charger review: Just about perfect</h2>
								<p>The totallee Wireless charger is just about perfect, from its slim and sleek design...</p>
							</div><!--blog-widget-text-->
							</a>
						</li>
											<li>
							<a href="https://techaeris.com/2020/01/19/huawei-watch-gt-2-46mm-series-now-available-in-canada/" rel="bookmark">
															<div class="blog-widget-img left relative">
									<img width="300" height="180" src="https://techaeris.com/wp-content/uploads/2020/01/Huawei-Watch-GT-2-300x180.jpg" class="widget-img-main wp-post-image" alt="Huawei Watch GT 2" srcset="https://techaeris.com/wp-content/uploads/2020/01/Huawei-Watch-GT-2-300x180.jpg 300w, https://techaeris.com/wp-content/uploads/2020/01/Huawei-Watch-GT-2-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />									<img width="80" height="80" src="https://techaeris.com/wp-content/uploads/2020/01/Huawei-Watch-GT-2-80x80.jpg" class="widget-img-side wp-post-image" alt="Huawei Watch GT 2" />																		<div class="feat-info-wrap">
										<div class="feat-info-views">
											<i class="fa fa-eye fa-2"></i> <span class="feat-info-text">53</span>
										</div><!--feat-info-views-->
																			</div><!--feat-info-wrap-->
																										</div><!--blog-widget-img-->
														<div class="blog-widget-text left relative">
																	<span class="side-list-cat">									
									Mobile / Wearables                                
                                 	</span>
																<h2>Huawei Watch GT 2 46mm Series now available in Canada</h2>
								<p>The Huawei Watch GT 2 retails for CA$299.99 (Sport) or $319.99 (Classic) at Visions...</p>
							</div><!--blog-widget-text-->
							</a>
						</li>
									</ul>
			</div><!--blog-widget-wrap-->
		</div><div id="mvp_tags_widget-2" class="foot-widget left relative mvp_tags_widget"><h3 class="foot-head">Popular Tags</h3>
			<div class="tag-cloud left relative">
				<a href="https://techaeris.com/tag/featured/" class="tag-cloud-link tag-link-6664 tag-link-position-1" style="font-size: 10px;">featured</a>
<a href="https://techaeris.com/tag/technology/" class="tag-cloud-link tag-link-1862 tag-link-position-2" style="font-size: 10px;">technology</a>
<a href="https://techaeris.com/tag/android/" class="tag-cloud-link tag-link-89 tag-link-position-3" style="font-size: 10px;">Android</a>
<a href="https://techaeris.com/tag/mobile/" class="tag-cloud-link tag-link-6083 tag-link-position-4" style="font-size: 10px;">Mobile</a>
<a href="https://techaeris.com/tag/xbox-one/" class="tag-cloud-link tag-link-2120 tag-link-position-5" style="font-size: 10px;">Xbox One</a>
<a href="https://techaeris.com/tag/google/" class="tag-cloud-link tag-link-741 tag-link-position-6" style="font-size: 10px;">Google</a>
<a href="https://techaeris.com/tag/apple/" class="tag-cloud-link tag-link-115 tag-link-position-7" style="font-size: 10px;">Apple</a>
<a href="https://techaeris.com/tag/ios/" class="tag-cloud-link tag-link-942 tag-link-position-8" style="font-size: 10px;">IOS</a>
<a href="https://techaeris.com/tag/business/" class="tag-cloud-link tag-link-6082 tag-link-position-9" style="font-size: 10px;">Business</a>
<a href="https://techaeris.com/tag/review/" class="tag-cloud-link tag-link-1569 tag-link-position-10" style="font-size: 10px;">Review</a>
<a href="https://techaeris.com/tag/tech/" class="tag-cloud-link tag-link-1859 tag-link-position-11" style="font-size: 10px;">tech</a>
<a href="https://techaeris.com/tag/samsung/" class="tag-cloud-link tag-link-1616 tag-link-position-12" style="font-size: 10px;">Samsung</a>
<a href="https://techaeris.com/tag/security/" class="tag-cloud-link tag-link-1666 tag-link-position-13" style="font-size: 10px;">Security</a>
<a href="https://techaeris.com/tag/iphone/" class="tag-cloud-link tag-link-951 tag-link-position-14" style="font-size: 10px;">iphone</a>
<a href="https://techaeris.com/tag/reviews/" class="tag-cloud-link tag-link-6085 tag-link-position-15" style="font-size: 10px;">Reviews</a>
<a href="https://techaeris.com/tag/playstation-4/" class="tag-cloud-link tag-link-2178 tag-link-position-16" style="font-size: 10px;">Playstation 4</a>
<a href="https://techaeris.com/tag/microsoft/" class="tag-cloud-link tag-link-1192 tag-link-position-17" style="font-size: 10px;">Microsoft</a>
<a href="https://techaeris.com/tag/gaming-2/" class="tag-cloud-link tag-link-699 tag-link-position-18" style="font-size: 10px;">gaming</a>
<a href="https://techaeris.com/tag/audio/" class="tag-cloud-link tag-link-162 tag-link-position-19" style="font-size: 10px;">Audio</a>
<a href="https://techaeris.com/tag/netflix/" class="tag-cloud-link tag-link-1286 tag-link-position-20" style="font-size: 10px;">Netflix</a>
<a href="https://techaeris.com/tag/movies/" class="tag-cloud-link tag-link-2711 tag-link-position-21" style="font-size: 10px;">movies</a>
<a href="https://techaeris.com/tag/entertainment-2/" class="tag-cloud-link tag-link-2731 tag-link-position-22" style="font-size: 10px;">entertainment</a>
<a href="https://techaeris.com/tag/smartphone/" class="tag-cloud-link tag-link-1717 tag-link-position-23" style="font-size: 10px;">Smartphone</a>
<a href="https://techaeris.com/tag/marvel/" class="tag-cloud-link tag-link-1147 tag-link-position-24" style="font-size: 10px;">Marvel</a>
<a href="https://techaeris.com/tag/games/" class="tag-cloud-link tag-link-697 tag-link-position-25" style="font-size: 10px;">Games</a>
<a href="https://techaeris.com/tag/lenovo/" class="tag-cloud-link tag-link-1051 tag-link-position-26" style="font-size: 10px;">Lenovo</a>
<a href="https://techaeris.com/tag/amazon/" class="tag-cloud-link tag-link-75 tag-link-position-27" style="font-size: 10px;">Amazon</a>
<a href="https://techaeris.com/tag/windows-10/" class="tag-cloud-link tag-link-3880 tag-link-position-28" style="font-size: 10px;">Windows 10</a>
<a href="https://techaeris.com/tag/headphones/" class="tag-cloud-link tag-link-828 tag-link-position-29" style="font-size: 10px;">Headphones</a>
<a href="https://techaeris.com/tag/tv/" class="tag-cloud-link tag-link-3446 tag-link-position-30" style="font-size: 10px;">TV</a>
<a href="https://techaeris.com/tag/privacy/" class="tag-cloud-link tag-link-1507 tag-link-position-31" style="font-size: 10px;">Privacy</a>
<a href="https://techaeris.com/tag/kickstarter/" class="tag-cloud-link tag-link-1016 tag-link-position-32" style="font-size: 10px;">Kickstarter</a>
<a href="https://techaeris.com/tag/forza/" class="tag-cloud-link tag-link-6989 tag-link-position-33" style="font-size: 10px;">Forza</a>
<a href="https://techaeris.com/tag/facebook/" class="tag-cloud-link tag-link-600 tag-link-position-34" style="font-size: 10px;">Facebook</a>
<a href="https://techaeris.com/tag/bluetooth/" class="tag-cloud-link tag-link-239 tag-link-position-35" style="font-size: 10px;">Bluetooth</a>
<a href="https://techaeris.com/tag/xbox/" class="tag-cloud-link tag-link-2115 tag-link-position-36" style="font-size: 10px;">Xbox</a>
<a href="https://techaeris.com/tag/auto-2/" class="tag-cloud-link tag-link-2565 tag-link-position-37" style="font-size: 10px;">auto</a>
<a href="https://techaeris.com/tag/sony/" class="tag-cloud-link tag-link-1748 tag-link-position-38" style="font-size: 10px;">Sony</a>
<a href="https://techaeris.com/tag/star-wars/" class="tag-cloud-link tag-link-2662 tag-link-position-39" style="font-size: 10px;">Star Wars</a>
<a href="https://techaeris.com/tag/xbox-360/" class="tag-cloud-link tag-link-2116 tag-link-position-40" style="font-size: 10px;">Xbox 360</a>			</div>

		</div>							</div><!--foot-widget-wrap-->
						</div><!--body-main-in-->
					</div><!--body-main-out-->
				</div><!--foot-top-->
				<div id="foot-bot-wrap" class="left relative">
					<div class="body-main-out relative">
						<div class="body-main-in">
							<div id="foot-bot" class="left relative">
								<div class="foot-menu relative">
									<div class="menu-footermenu-container"><ul id="menu-footermenu" class="menu"><li id="menu-item-38199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38199"><a href="https://techaeris.com/about/">About Us</a></li>
<li id="menu-item-38198" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38198"><a href="https://techaeris.com/terms-conditions/">Terms and Conditions</a></li>
<li id="menu-item-38197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-38197"><a href="https://techaeris.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>								</div><!--foot-menu-->
								<div class="foot-copy relative">
									<p>© 2013-2019 MagnaAquila Media. All Rights Reserved.</p>
								</div><!--foot-copy-->
							</div><!--foot-bot-->
						</div><!--body-main-in-->
					</div><!--body-main-out-->
				</div><!--foot-bot-->
			</footer>
		</div><!--body-main-wrap-->
	</div><!--site-wrap-->
</div><!--site-->
<div class="fly-to-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
	<span class="to-top-text">To Top</span>
</div><!--fly-to-top-->
<div class="fly-fade">
</div><!--fly-fade-->

<!-- LionScripts: Webmaster Tools Foot Start -->

							<script>
							  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
							  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
							  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
							  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
					
							  ga('create', 'UA-48083147-1', 'techaeris.com');
							  ga('send', 'pageview');
							</script>
							
<!-- LionScripts: Webmaster Tools Foot End -->

<script type="text/javascript">
jQuery(document).ready(function($) {

	// Back to Top Button
    	var duration = 500;
    	$('.back-to-top').click(function(event) {
          event.preventDefault();
          $('html, body').animate({scrollTop: 0}, duration);
          return false;
	});

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

	  	$(".comment-click-162236").on("click", function(){
  	  $(".com-click-id-162236").show();
	  $(".disqus-thread-162236").show();
  	  $(".com-but-162236").hide();
  	});
	
	// Infinite Scroll
	$('.infinite-content').infinitescroll({
	  navSelector: ".nav-links",
	  nextSelector: ".nav-links a:first",
	  itemSelector: ".infinite-post",
	  loading: {
		msgText: "Loading more posts...",
		finishedMsg: "Sorry, no more posts"
	  },
	  errorCallback: function(){ $(".inf-more-but").css("display", "none") }
	});
	$(window).unbind('.infscr');
	$(".inf-more-but").click(function(){
   		$('.infinite-content').infinitescroll('retrieve');
        	return false;
	});
	$(window).load(function(){
		if ($('.nav-links a').length) {
			$('.inf-more-but').css('display','inline-block');
		} else {
			$('.inf-more-but').css('display','none');
		}
	});

$(window).load(function() {
  // The slider being synced must be initialized first
  $('.post-gallery-bot').flexslider({
    animation: "slide",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    itemWidth: 80,
    itemMargin: 10,
    asNavFor: '.post-gallery-top'
  });

  $('.post-gallery-top').flexslider({
    animation: "fade",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    	  prevText: "&lt;",
          nextText: "&gt;",
    sync: ".post-gallery-bot"
  });
});

});

</script>

		<!-- Root element of PhotoSwipe. Must have class pswp. -->
		<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">

		    <!-- Background of PhotoSwipe. 
		         It's a separate element as animating opacity is faster than rgba(). -->
		    <div class="pswp__bg"></div>

		    <!-- Slides wrapper with overflow:hidden. -->
		    <div class="pswp__scroll-wrap">

		        <!-- Container that holds slides. 
		            PhotoSwipe keeps only 3 of them in the DOM to save memory.
		            Don't modify these 3 pswp__item elements, data is added later on. -->
		        <div class="pswp__container">
		            <div class="pswp__item"></div>
		            <div class="pswp__item"></div>
		            <div class="pswp__item"></div>
		        </div>

		        <!-- Default (PhotoSwipeUI_Default) interface on top of sliding area. Can be changed. -->
		        <div class="pswp__ui pswp__ui--hidden">

		            <div class="pswp__top-bar">

		                <!--  Controls are self-explanatory. Order can be changed. -->

		                <div class="pswp__counter"></div>

		                <button class="pswp__button pswp__button--close" title="Close (Esc)"></button>

		                <button class="pswp__button pswp__button--share" title="Share"></button>

		                <button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>

		                <button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>

		                <!-- Preloader demo http://codepen.io/dimsemenov/pen/yyBWoR -->
		                <!-- element will get class pswp__preloader-active when preloader is running -->
		                <div class="pswp__preloader">
		                    <div class="pswp__preloader__icn">
		                      <div class="pswp__preloader__cut">
		                        <div class="pswp__preloader__donut"></div>
		                      </div>
		                    </div>
		                </div>
		            </div>

		            <div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
		                <div class="pswp__share-tooltip"></div> 
		            </div>

		            <button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
		            </button>

		            <button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
		            </button>

		            <div class="pswp__caption">
		                <div class="pswp__caption__center"></div>
		            </div>

		        </div>

		    </div>

		</div>
		<link rel='stylesheet' id='kiwi_social_sharing_pro-frontend-css'  href='https://techaeris.com/wp-content/plugins/kiwi-social-share-pro/assets/css/frontend.min.css?ver=2.0.7' type='text/css' media='all' />
<script type='text/javascript' src='https://www.dwin2.com/pub.548685.min.js?ver=33dd237756b33595f16a54a634b8bf77'></script>
<script type='text/javascript' src='https://techaeris.com/wp-includes/js/comment-reply.min.js?ver=33dd237756b33595f16a54a634b8bf77'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/techaeris.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"techaeris"};
/* ]]> */
</script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"162236 https:\/\/techaeris.com\/?p=162236","disqusShortname":"techaeris","disqusTitle":"SteelSeries adds two new Apex keyboards, Rival mouse to lineup","disqusUrl":"https:\/\/techaeris.com\/2020\/01\/21\/steelseries-adds-two-new-apex-keyboards-rival-mouse-to-lineup\/","postId":"162236"};
/* ]]> */
</script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/reviewer/public/assets/js/jquery.nouislider.all.min.js?ver=3.14.1'></script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/reviewer/public/assets/js/photoswipe.js?ver=3.14.1'></script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/reviewer/public/assets/js/jquery.knob.js?ver=3.14.1'></script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/reviewer/public/assets/js/reviewer.public.min.js?ver=3.14.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerRatingObj = {"ajax_nonce":"e414afac31","ajax_url":"https:\/\/techaeris.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_rating"};
var reviewerJudgeObj = {"ajax_nonce":"cf52d76659","ajax_url":"https:\/\/techaeris.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_like"};
var reviewerQueryURs = {"ajax_nonce":"01e8dd73a3","ajax_url":"https:\/\/techaeris.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/reviewer/public/assets/js/reviewer-reviews-boxes.js?ver=3.14.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerQueryAllURs = {"ajax_nonce":"38698987c7","ajax_url":"https:\/\/techaeris.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_all_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/reviewer/public/assets/js/reviewer-widget-users-reviews.js?ver=3.14.1'></script>
<script type='text/javascript' src='https://techaeris.com/wp-content/themes/flex-mag/js/scripts.js?ver=33dd237756b33595f16a54a634b8bf77'></script>
<script type='text/javascript' src='https://techaeris.com/wp-content/themes/flex-mag/js/jquery.infinitescroll.min.js?ver=33dd237756b33595f16a54a634b8bf77'></script>
<script type='text/javascript' src='https://techaeris.com/wp-content/themes/flex-mag/js/retina.js?ver=33dd237756b33595f16a54a634b8bf77'></script>
<script type='text/javascript' src='https://techaeris.com/wp-includes/js/wp-embed.min.js?ver=33dd237756b33595f16a54a634b8bf77'></script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/kiwi-social-share-pro/assets/js/kiwi.min.js?ver=2.0.7'></script>
<script type='text/javascript' src='https://techaeris.com/wp-content/plugins/kiwi-social-share-pro/assets/js/frontend.min.js?ver=2.0.7'></script>
<script src="//www.anrdoezrs.net/am/8961846/impressions/page/am.js"></script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=4&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=4&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="techaeris_com",_audins_did=71059;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-4");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.techaeris_com,DomainId.71059" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'>(function(){function b(e,c){for(var d=0;d<c.length;d++){var f=c[d];if(0==f.complete||"undefined"!=typeof f.readyState&&4>f.readyState){var g=f.getAttribute("src")||f.currentSrc;"undefined"!=typeof f.readyState&&0==f.readyState?f.addEventListener("loadstart",function(h){var k=h.getAttribute("src")||h.currentSrc;window.ezorqs(h,k)}):(g=f.getAttribute("src")||f.currentSrc,window.ezorqs(f,g));f.addEventListener("load",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,
	k)});f.addEventListener("loadeddata",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)});f.addEventListener("error",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)})}}}function a(e){for(var c=0;c<document.styleSheets.length;c++)if(document.styleSheets[c].href==e)return!0;return!1}b("img",document.querySelectorAll("img"));b("video",document.querySelectorAll("video"));b("audio",document.querySelectorAll("audio"));
	(function(e){for(var c=0;c<e.length;c++){var d=e[c];if(("preload"==d.getAttribute("rel")||"stylesheet"==d.getAttribute("rel"))&&null!=d.getAttribute("href")&&a(d.getAttribute("href"))){window.ezorqs(d,d.getAttribute("href"));var f=document.createElement("img");f.onerror=function(g){"undefined"!=typeof g.path&&"undefined"!=typeof g.path[0].currentSrc?window.ezorqe(d,g.path[0].currentSrc):"undefined"!=typeof g.srcElement&&"undefined"!=typeof g.srcElement.href&&window.ezorqe(d,g.srcElement.href)};f.src=
	d.getAttribute("href")}}})(document.querySelectorAll("link"));"undefined"!=typeof window.__ez.ssaf&&-1<window.__ez.ssaf.indexOf(16)&&"undefined"!==typeof window.__ez.sshsdef&&!1===window.__ez.sshsdef&&Element.prototype.addEventListener&&("function"==typeof window.onload&&(window.addEventListener("load",window.onload),window.onload=null),"function"==typeof document.onload&&(document.addEventListener.addEventListener("load",document.onload),document.onload=null))})();</script></body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced 

Served from: techaeris.com @ 2020-01-21 15:45:43 by W3 Total Cache
-->